IPB

Welcome Guest ( Log In | Register )

"Allergic reactions" of helicopter models - need help to find out, Ported helicopters from Demon_from_pripyat have an unknown error
bluehawk112
post Sep 26 2017, 03:39 PM
Post #1


Dishonorable Discharge
****

Group: Guests
Posts: 238
Joined: 5-February 14
From: Planet DO THIS FOR ME OR I HATE U
Member No.: 10,005



Hello guys,

I really could need some help from modelling specialists here:
please, whoever can investigate my uploaded Battlehawk helicopter (coming from Demon_from_pripyatīs mod) would do me (and Demon) a big favour!!!
Download helicopter here (easy to implement in vanilla BF2, read description that comes with the helicopter):
edit: link removed

I used the term "allergic reactions" because the problem with this helicopter (and most of Demon_from_pripyatīs other helicopters) is this:
When sitting in the helicopter and hovering close to

- all sorts of man made buildings or
- concrete landing surfaces or
- wooden bridges

or standing on the ground with this helicopter close to these objects, the frame rate suddenly drops to 2-3 frames/sec (or even less).
There might be more objects, I donīt know...This can even happen with the helicopter positioned as described above but with your own person being outside the helicopter.

It has nothing to do with my added weapons or my changed flight dynamics since Demon_from_pripyat experienced the same in his mod.
It seems to be a major (modelling?) issue because nearly all of his ported helicopters are affected.
Who can help?
Thanks guys

This post has been edited by bluehawk112: Sep 29 2017, 12:47 PM
Go to the top of the page
 
+Quote Post
 
Start new topic
Replies (1 - 13)
Fastj@ck
post Sep 27 2017, 10:15 AM
Post #2


Major
****

Group: Soldiers
Posts: 274
Joined: 24-August 08
From: Germany
Member No.: 5,523



Depends how ultra cool realistic detailed the choppers are modelled or the other objects.
Ahh wait missed the part with when you come close to bridges.

This post has been edited by Fastj@ck: Sep 27 2017, 10:18 AM
Go to the top of the page
 
+Quote Post
bluehawk112
post Sep 27 2017, 10:39 AM
Post #3


Dishonorable Discharge
****

Group: Guests
Posts: 238
Joined: 5-February 14
From: Planet DO THIS FOR ME OR I HATE U
Member No.: 10,005



Hi Fastj@ck, did you download the chopper? Itīs very detailed from outside view but not many details when sitting in the cockpit - so itīs obviously not a polygone thing (rendering too many polygones)...
Go to the top of the page
 
+Quote Post
Fastj@ck
post Sep 27 2017, 11:35 AM
Post #4


Major
****

Group: Soldiers
Posts: 274
Joined: 24-August 08
From: Germany
Member No.: 5,523



That doesn't help you much because i'm sure it would do the same in my game. Laggy. I would suggest first Demon to look into the Tris count of the choppers.

When the model is to uLTrA DetaILEd mOdeLLed In DetAIlS, it hurts the engine like your eyes by reading the red words. Calculating things like collisionmeshes etc. Also maybe the re export isn't done correctly.
When you load the chopper into the BF editor, its starts lagging in the editor too? And i know nothing about modelling or Modelling software.

Importing vehicles from newer games like BF3/4 etc. (made in high tris counts , so really detailed) doesn't run well in this old BF2 engine.

This post has been edited by Fastj@ck: Sep 27 2017, 11:38 AM
Go to the top of the page
 
+Quote Post
bluehawk112
post Sep 27 2017, 12:29 PM
Post #5


Dishonorable Discharge
****

Group: Guests
Posts: 238
Joined: 5-February 14
From: Planet DO THIS FOR ME OR I HATE U
Member No.: 10,005



Yeah, but itīs strange that the fps drop also occurs on concrete landing surfaces whereas the fps drop is not present when f.e. hovering close to a bunch of palm trees.
In my point of view -and Iīm not a modeller either - there might be something wrong with the helicopterīs material mapping / collision mesh. I canīt load it into the editor because I donīt have any bfeditor and I wouldnīt know how to use it, thatīs why I requested some help from other forum members here. Perhaps some of them know what might have gone wrong with the modelling.
So thanks Fastj@ck for trying, but I think we both are pretty clueless here... wink.gif

This post has been edited by bluehawk112: Sep 27 2017, 12:32 PM
Go to the top of the page
 
+Quote Post
Fastj@ck
post Sep 27 2017, 03:27 PM
Post #6


Major
****

Group: Soldiers
Posts: 274
Joined: 24-August 08
From: Germany
Member No.: 5,523



QUOTE
I canīt load it into the editor because I donīt have any bfeditor and I wouldnīt know how to use it, thatīs why I requested some help from other forum members here.


Achso. Wasn't aware about that you dont have the BF Editor I will take a look tommorrow.

Ähm wait:

http://www.realitymod.com/forum/f26-pr-bf2...ding-hueys.html

FYI, I am Jabil_One. Check that post out. I looked into your rotortweaks and it calls the uh60 collisionmeshes. This collision meshes arent in the folder. I know, check link, that calling rotors from another folder causes lags in the editor. Rhino said it doesn't matter, not affecting ingame but i believe he didn't catched that i meant the SP variant.

2 options:

Change tweakline of the collisionmeshes of both rotors to the right one in the folder or copy/paste the uh60 rotor collision etc. into the folder of your lagging choppers.

This post has been edited by Fastj@ck: Sep 27 2017, 03:32 PM
Go to the top of the page
 
+Quote Post
bluehawk112
post Sep 27 2017, 03:56 PM
Post #7


Dishonorable Discharge
****

Group: Guests
Posts: 238
Joined: 5-February 14
From: Planet DO THIS FOR ME OR I HATE U
Member No.: 10,005



Hey thank you very much, Fastj@ck for not giving up on me happy.gif , but I have to disappoint you:
It was me who changed the mainrotor. Unfortunately, the problem existed already before I changed it.
So, this is most likely not the cause sad.gif ...But I will try
-and I really appreciate your efforts laugh.gif , no sh_it, thanks man
cheers

This post has been edited by bluehawk112: Sep 27 2017, 04:03 PM
Go to the top of the page
 
+Quote Post
Fastj@ck
post Sep 27 2017, 03:59 PM
Post #8


Major
****

Group: Soldiers
Posts: 274
Joined: 24-August 08
From: Germany
Member No.: 5,523



But you didnt added the collisionmeshes into the same folder or did ya with the right names.?
Go to the top of the page
 
+Quote Post
bluehawk112
post Sep 27 2017, 04:36 PM
Post #9


Dishonorable Discharge
****

Group: Guests
Posts: 238
Joined: 5-February 14
From: Planet DO THIS FOR ME OR I HATE U
Member No.: 10,005



I just tried what you suggested, but no success...
I put the main- and tailrotor meshes of the usthe_uh60 into the main and tailrotor meshfolders of the battlehawk. Additionally, I put the main- and tailrotor meshfolders of the usthe_uh60 in the folder of the battlehawk. Additionally, I put the folder of the usthe_uh60 (with all its rotor- and meshfolders) in the vehicles/air folder.
Basically, I tried everything - no change, sad...
but thanks anyhow Fastj@ck
Go to the top of the page
 
+Quote Post
Fastj@ck
post Sep 28 2017, 05:05 AM
Post #10


Major
****

Group: Soldiers
Posts: 274
Joined: 24-August 08
From: Germany
Member No.: 5,523



I loaded the s70 BH into the BF Editor after i fixed the missing collisionmeshes laggyness of the rotors. The original rotors is in my opinion not causing the problems.
You could test it by replacing others rotors of chopper and give them the s70 main/tail rotors.

I catched one error in the debug bar. I'm sure clive knows more about that.
Ignored Warning[Physics] : collisionMesh error, part:0 geom:0 no LOD 0 found. LodCount:3 faulty file:objects/weapons/armament/missiles/smawrocket/Meshes/smawrocket.collisionMesh


Remove the SMAW from the chopper and test again.

After that i ran the helcopter wizard for the BF and saw many errors about networkableinfos and missing rotationals.
See Imgur Pic.

https://imgur.com/a/qGSDZ
Go to the top of the page
 
+Quote Post
MasterChiefRulZ
post Sep 28 2017, 06:52 AM
Post #11


You know the drill...
Group Icon

Group: Mr. Admin
Posts: 10,421
Joined: 31-December 03
From: Home
Member No.: 48



I'm no model expert, and I didn't sleep at a holiday inn express last night, but from what it *sounds* like... this model is poorly optimized in it's export to BF2.


--------------------
Go to the top of the page
 
+Quote Post
bluehawk112
post Sep 28 2017, 07:54 AM
Post #12


Dishonorable Discharge
****

Group: Guests
Posts: 238
Joined: 5-February 14
From: Planet DO THIS FOR ME OR I HATE U
Member No.: 10,005



Thanks guys for your support, very kind of you! And thank you, Fastj@ck for your investigation with the editor - this might be very helpful. The SMAW rocket was created by me, so it canīt be the reason for fps drop either (as I said, Demon experienced the same in his mod and the issue has been existing before I added some stuff to the helicopter already...).
Although the items on the list of the imgur picture shouldnīt cause fps drops, you never know...
Perhaps the strength of the dampers/landing gear etc. or the networkable info stuff are the troublemakers in the end, weīll see.
I will report back, thank you
so long
Go to the top of the page
 
+Quote Post
Fastj@ck
post Sep 28 2017, 10:10 AM
Post #13


Major
****

Group: Soldiers
Posts: 274
Joined: 24-August 08
From: Germany
Member No.: 5,523



I would try to test your SMAW on another chopper so you know atleast if your smaw works good ingame.
Go to the top of the page
 
+Quote Post
bluehawk112
post Sep 28 2017, 01:52 PM
Post #14


Dishonorable Discharge
****

Group: Guests
Posts: 238
Joined: 5-February 14
From: Planet DO THIS FOR ME OR I HATE U
Member No.: 10,005



QUOTE (bluehawk112 @ Sep 27 2017, 08:29 PM) *
Yeah, but itīs strange that the fps drop also occurs on concrete landing surfaces whereas the fps drop is not present when f.e. hovering close to a bunch of palm trees.
In my point of view -and Iīm not a modeller either - there might be something wrong with the helicopterīs material mapping / collision mesh. I canīt load it into the editor because I donīt have any bfeditor and I wouldnīt know how to use it, thatīs why I requested some help from other forum members here. Perhaps some of them know what might have gone wrong with the modelling.
So thanks Fastj@ck for trying, but I think we both are pretty clueless here... wink.gif



Okay guys, thanks for trying to help me but my first guess was correct. The reason for the fps drop is definitely a faulty collision mesh.
I found out what it was by doing these 2 steps:

Step 1: Put the collision mesh file of BF2īs UH60 into the meshfolder of the battlehawk, like this:
vehicles/air/s70_battlehawkii/Meshes/USTHE_UH60.collisionMesh

Step 2: Ammend the s70_battlehawkii.tweak and the s70_battlehawkii.con files:
replace the line "ObjectTemplate.setCollisionMesh s70_battlehawkii" with a new line, now to read:
"ObjectTemplate.setCollisionMesh USTHE_UH60"

So, as you can see, I simply exchanged the collisionmesh. The battlehawk has now the collisionmesh of the vanilla BF2 UH60.
All stuttering is gone, no more fps drop when approaching buildings or concrete surfaces...
I will ask Demon to recreate new collisionmeshes for his ported helicopters.
Thanks Fastj@ck for the hint to put "foreign" collisionmesh files into the mesh folder of the lagging chopper when exchanging collisionmeshes!(post nr6) clapclap.gif
Hereīs the corrected battlehawk:

edit: link removed

Thread can be closed, thanks for your interest wink.gif

This post has been edited by bluehawk112: Sep 29 2017, 05:27 PM
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 20th October 2017 - 05:10 PM